Recent Posts

Pages: 1 2 3 [4] 5 6 7 8 9 10
31
General Server Discussion / Re: My account deleted?
« Last post by Rider_Blade on November 25, 2018, 09:14:09 am »
As far as I know - admins not deleted accounts without reasons and for inactive accounts not deleted.
Maybe you just changed nickname and forgot about it? If yes, admins can check logs.
32
Off-Topic / Re: Deceptive Site Ahead
« Last post by Rider_Blade on November 25, 2018, 09:10:52 am »
Maybe need just change some settings in the browser. I remember that in some browsers that's happen to me. But not on this site.
The secure HTTPS Protocol. Now you can join only on such sites without this "error".
Btw which browser you use?  No sense use virus scan - maybe only if for the prevention. But problem most likely not in viruses.
Last time i use browser Opera and not have problems.
33
Off-Topic / Re: Deceptive Site Ahead
« Last post by Goodfella on November 25, 2018, 01:19:37 am »
Happened to me several times,i just skip it and press visit this unsafe site. 8) :L
34
Off-Topic / Re: Deceptive Site Ahead
« Last post by [MAF]Snoopy on November 24, 2018, 06:02:24 pm »
Suppose I better do a virus scan :L thanks
35
Off-Topic / Re: Deceptive Site Ahead
« Last post by Rider_Blade on November 24, 2018, 05:21:17 pm »
Never.
36
Media / Re: Screenshots
« Last post by Rider_Blade on November 24, 2018, 05:20:14 pm »
Some screens with my ban evades :L



37
Off-Topic / Re: Deceptive Site Ahead
« Last post by Troublemaker on November 24, 2018, 04:01:44 pm »
Nah, all working fine here. You need to start visiting obscene websites in incognito, too many viruses man.
38
Media / Re: Screenshots
« Last post by Troublemaker on November 24, 2018, 04:00:16 pm »


That's a better punishment than being kicked for afking at spawn  :L
39
Media / Re: Screenshots
« Last post by Frostballe on November 24, 2018, 03:56:30 pm »


Old screen from when Ush decided to go afk at spawn of a long SK and became a involuntary victim of a bukkake. He never really recovered sadly..
40
Off-Topic / Deceptive Site Ahead
« Last post by [MAF]Snoopy on November 24, 2018, 02:38:46 pm »
Anyone else get this when trying to access this website?

Pages: 1 2 3 [4] 5 6 7 8 9 10